Jump to content
Sign in to follow this  
Rico Cremer

Can't get kextd port, AppleACPICPU timed out, waiting for DSMOS

Recommended Posts

Can't get kextd port, AppleACPICPU timed out, waiting for DSMOS


I am running into a weird problem. I am currently running macOS Sierra 10.12.3. At the time of installing it was 10.12.2, which I eventually updated to 10.12.3 without problems. I installed it vanilla. I will describe the process:

(I was on El Capitan at this time)

  1. I downloaded Sierra 10.12.2 from the App Store
  2. I restored the Sierra Installer to my 16GB USB 2.0 stick using the following method:
    1. I mounted the InstallESD.dmg image, found inside the Sierra installer app package
    2. I restored the BaseSystem.dmg image, found inside the InstallESD.dmg image, to my usb using Disk Utility
    3. I copied over the packages folder inside the InstallESD.dmg image, to the /system/installation folder on my USB stick
    4. I copied over "BaseSystem.dmg", "AppleDiagnostics.dmg", "BaseSystem.chunklist" and "AppleDiagnostics.chunklist" files from the InstallESD.dmg to the root of my USB stick
  3. I used Pacifist to extract the kernel, and placed it in the /System/Library/Kernels folder on my USB Stick
  4. Installed Enoch rev.2839 to my USB stick
  5. Installed Sierra just fine

Now, I replaced my harddrive with an 120GB SSD and wanted to do a clean install of macOS on it. So I downloaded Sierra 10.12.3 from the AppStore and followed the same procedure as described above, booted my system from the usb installer and.... Nothing. I am getting a weird error:

Can't get kextd port.
busy timeout[0]. (240s), kextd wait(0); 'AppleACPICPU', 'display', 'pci1002,aa98', 'AZAL', 'IOUSBHostInterface', 'IOUSBHostInterface', 'IOUSBHostInterface', 'PX43', 'UAR1', 'UAR2', 'IOResources'
Waiting for DSMOS...

And there it freezes.

Like I said, I've installed Sierra 10.12.2 before and did not have any issues so I don't understand completely why it won't let me do a clean install of Sierra 10.12.3. Other than the harddrive, nothing else changed, so I thought it might be because of the SSD. Though, booting up the installer with the old harddrive in gives me the same result.

Any ideas?

Thanks in advance

Motherboard: NEC VL280U, Intel G33/P35 chipset
CPU: Intel Core2Quad Q9450, 2,66Ghz
RAM: 4GB (2x2GB) DDR2 667Mhz
GFX: Sapphire Radeon HD 6450, 1GB Low-Profile


Share this post

Link to post
Share on other sites

Nevermind, I fixed it already. I think something went wrong with copying fakesmc.kext to /extra/extensions. I copied it again and now the installer boots without problems.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...