Jump to content
Sign in to follow this  

AMD FX - Instant Reboot

Recommended Posts

Hello Mac On PC,
Yesterday I prepped a USB stick (SanDisk Ultra Fit 32GB USB3.0) for my AMD system.
My build specs are these:
- AMD FX-8350 Black Edition
- Asus Sabertooth 990FX R2.0 (Also, AI Tweaker/Overclock settings are resetted to stock too.)
- MSI GeForce GTX 760 2GB Gaming (N760 TF 2GD5/OC)
- Crucial Ballistix Tactical BLT2C8G3D1608ET3LX0CEU (2x 8GB)
Besides a USB mouse, and a PS2 keyboard, I've connected an Samsung 840 Pro SSD (internal via SATA), on which I want to install OSX.
After switching several options in the UEFI, to make it compatible, I tried booting the USB stick.
After it boots, I tried to start the Yosemite partition, with this flag: ": /amdfx", but this resulted in a Instant Reboot. Which should be a Haswell thing?
Besides ": /amdfx" I tried things like "-x", "NPCI=0x3000", "GraphicsEnabler=Yes", "cpus=1", "maxmem=4096", and variations, combinations of them.
I also tried to load a different Kernel from a storage device, "mach_10.10_all_amd_rc7" from Bronya.
It seems a UEFI setting, the "Execute Disable Bit", could be causing the Instant Reboot. But I cannot seem to find it anywhere in my UEFI settings, is it an Intel thing?
Any help with this would be greatly appreciated. :)
Thanks in advance!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...