Jump to content
Sign in to follow this  

Disk Utility on MBR partition not working

Recommended Posts





I am trying to installing Yosemite on my ASUS laptop with Niresh's amazing distro 10.10.1.


I have a ~100GB partition (MBR) that I am willing to use to install Yosemite, but when I have to use Disk Utility to erase and format it, I get the message "Mediakit reports not enough space ...". From what I have understood the MBR partition should not be a problem since the distro is already MBR patched.

I have tried to leave that space completely free (not partitioned), with no results. I have also tried distro 10.10.0.

(I am trying to avoid to format the whole disk to partition it in GUID).


Is it possible that I am doing something wrong? Is it possible that this is linked to some boot options or bios settings?


Thank you very much

And thank you very much Niresh for your amazing work







I found out that, even if Niresh's distro is correctly MBR patched, Mac OS installation has problem if the EFI partition on your computer is <200Mb.

Problem: the default EFI partition of Windows 8.1 (and others) installation is ~100Mb --> Too small!! <--


There is a good thread on this problem here:



Reply #13 was almost perfect for my case

The point is that you have to expand this EFI partition, but ordinary tools and software won't allow you to access it, since it is reserved to the system.

You need to take some patience and:

- build a bootable Windows USB

- usd DISKPART tool

- erased the Recovery Partition (it is not necessary, while the space it occupies is)

- made a backup of the EFI partition

- erased EFI partition too

- created a new bigger EFI partition

- copied in it the content of the old one form the backup


Windows still boots, and Disk Utility finally works properly


** note 1: what didn't work for me form the mentioned reply #13 of the linked thread: (Read the thread before this)

I couldn't manage to assign a letter to the EFI partition, it looks like "assign" does not work on partition, but only on volumes.

So you have to list volumes, and select the one formatted in FAT32 with size ~100Mb, and then assign a letter to it (e: in the example). Then everything goes as written there.

NOTICE: Look for some guide on how DISKPART tool works and get an idea of what commands do. It is a very powerful tool and you risk to erase everything from your disk if you do not know what you are doing


** note 2: refer to the linked thread to understand what is going on, I am not an expert and I just got an idea of what I had to do. I can't give you more information


** note 3: this is a problem that probably a lot of people who bought a pre-assembled computer with pre-installed windows face. Wouldn't it be a good idea to mention it in Yosemite Zone installation guide or in the FAQs?

  • Like 1

Share this post

Link to post
Share on other sites

Even a "duplicate post, dumbass" answer would be appreciated.

I have spent some days going through forums and attempts, but everyone having a similar problem seem to solve it with the MBR patch, that in this case is already present

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...