Jump to content
Sign in to follow this  
Rico Cremer

[SOLVED] AMDRadeonx4000.kext stuck at blank screen and spinning wheel

Recommended Posts


I installed Yosemite Zone 10.10.1 without any problems on my system. The only problem I encounter is with my XFX Radeon HD 7850 Core edition graphics card. I can only boot my system in safe mode. When i boot normally it hangs at a blank screen with spinningwheel. When i delete AMDRadeonX4000.kext from /S/L/E it works fine, though my graphics are pretty laggy then. Verbose mode doesn't really give me an error about the kext. The only thing that came to my notice is that it says "GPU hardware VM enabled".

I made a backup of the kext, booted normally without it, used kext wizard to install it again and manually loaded it in the terminal to see if it'd give me any errors, but none.

The system recognizes my gfx as amd radeon 7xxx series and uses my native resolution (1920x1080).

I tried GraphicsEnabler=Yes/ No, Yes gives me a memory allocation error so I can only use No.

My system is

CPU: AMD FX 8120 8-core cpu

MOBO: ASRock 970 extreme3 r2.0

GFX: XFX Radeon HD7850 Core edition (1GB DDR5)

16GB DDR3 Dual Channel Ram

Any help would be appreciated, since other than my gfx everthing works fine.

Thanks in advance

Share this post

Link to post
Share on other sites

I am having exactly same problem installing Yosemite 10.10.1 on a similar build. I did not try to delete any kexts yet.


My build

AMD FX 8150

GPU = HIS 7850 2GB

Motherboard = Asus m5a99x evo




I will update if I find any solution

Share this post

Link to post
Share on other sites

@Rico81 @gentie Backup all the graphics kexts

there is an option in customize section of yosemite Installer

Share this post

Link to post
Share on other sites

I fixed it already by going into safe mode (bootflag -x), since the x4000 kext is not allowed to load while in safe mode. From there I replaced  IOPCIFamily.kext with one that I found in another topic in this forum, I can't remember where though. the X4000.kext was able to load and I had complete acceleration. Though, my graphics card was still identified as a 7xxx series graphics card and booting with GE=Yes caused a memory allocation error in ati.c. I fixed that error by loading the C library module in Chameleon Wizard. The only problem I had afterwards was that my Graphics card was recognized as Aji with 4 connectors. I have 5 connectors and the connector table was wrong. (It said Display Port, Display Port, DVI-D, HDMI) but my graphics card is DVI-D, DVI-I, HDMI, Display Port, Display Port) so i changed the connectors table in the amd7000controller.kext to match at least my first DVI-D connector. Everything works fine now:

Ricos-Mac-Pro:~ rico$ ioreg | grep ATY
    | |   |   | +-o ATY,Aji@0  <class AtiFbStub, id 0x1000002c6, registered, matched, active, busy 0 (196 ms), retain 8>
    | |   |   | +-o ATY,Aji@1  <class AtiFbStub, id 0x1000002c7, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | +-o ATY,Aji@2  <class AtiFbStub, id 0x1000002c8, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | +-o ATY,Aji@3  <class AtiFbStub, id 0x1000002c9, registered, matched, active, busy 0 (0 ms), retain 8>



The only weird problem I have now is that the computer doesn't save my work. For example, when i change the default program to open a certain file, it's back to its default after I reboot. Sleep works flawless, though after standby my mouse, keyboard and monitor won't power on.


edit: IOPCIFamily.kext --> http://www.mediafire.com/download/q1sosygys8m4zlt/IOPCIFamily.kext.zip

Edited by Rico81

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...