Jump to content
Sign in to follow this  

MSI B85M-P33 - Can't boot installer, instant restart no matter what flags are used

Recommended Posts



After a few years long break from Hackintosh I'm trying to get back with my "new" PC. Unfortunately I didn't build it with Hackintosh in mind so I guess my motherboard is incompatible / has some problems. First, the spec:


CPU: i5 4440

GPU: Gigabyte GTX 660 2GB




I downloaded latest Niresh Yosemite and made a bootable USB using TransMac. However, once I boot up from it and choose "Yosemite-Zone", my PC instantly restarts just after seeing Mac On PC logo for a second. I tried booting with all kinds of flags. GraphicsEnabler=Yes/No, PCIRootUID=0/1, -x, -v, ncpci=0x2000 etc. Nothing, always the same. When I boot in verbose mode I can't even see any error. Back in the days when I was installing Snow Leo, booting with -v resulted with installer getting stuck at the error so I could see what's going on. Now its different, even when I boot with -v I can see kexts loading up but then it just restarts without giving me an error.


I set all the things I could in my MOBO's settings according to installation guide. Booting mode is set from "UEFI" to "Legacy+UEFI" (that's all I have, don't have typical "Legacy" or "UEFI=Disabled"), HPET is enabled (I can only choose enabled/disabled, don't have an option to set it to 64-bit), disks run on AHCI. I tried booting using my NVIDIA GTX 660 and  internal graphics - always the same. I even unplugged completely my GTX 660 and run strictly on internal card - same thing. I even tried to unplug all the hard drives just to see if the installer boots up - nothing helps.


So I guess the last thing that might prevent me from booting up is my MOBO. I digged through all the settings and I set everything correctly as much as I could - the settings on my mobo are kind of limited so not much to change :/ Is it possible that I need to patch my BIOS? I heard there is some pmpatch and uefipatch. Which one to choose? Is UEFIPatch really needed if I'm not using full UEFI boot mode?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...