Jump to content
Sign in to follow this  

VirtualBox Yosemite stuck.... AppleKextExcludeList

Recommended Posts



Firs of all, it's my first post on this forum so thanks hackintosh for your work, this is great.


I'm trying to install Yosemite as a virtual mahcine (VirtualBox) on my Windows laptop- (lenovo haswell)

I tried several images but none work (last one is 10.10.1, since the 10.10.2 link is unavailable), even the preinstalled ones (vdi images), i always got stuck.


I tried all flags I could (/haswell -x, -v,....) but nothing works.

The only thing relevant  I found is that it freezes at loading the kext "AppleKextExcludeList", wich I extracted and open in an editor : a lot of references of virtualbox are here. If the name corresponds to what it stands for, it's clear to me that I 'll never be able to run these images under VirtualBox.


I tried to create my own bootable iso, but this seems pretty hard to accomplish under a windows environment (even with magic iso support of HFS+)


Maybe I've gone too far, but I'm really stuck here, so any help would be appreciated.


Share this post

Link to post
Share on other sites

Well, I don't know if this will help anyone else, but I was having a hard time getting the Yosemite to boot up in Virtualbox without using the "-x" option (safe mode).

I did some experiments and finally found a way for it to boot fast.


When booting, I have to use the option "UseKernelCache=No"

After using that option, the osx boots up fine. :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...