Jump to content
Sign in to follow this  

No Sound with Mavericks Niresh on VirtualBox

Recommended Posts



I've installed Mavericks Niresh on Virtualbox per the tutorial here:



The installation went smoothly and the OS came up like a charm.  Everything except one thing:  I have no sound.


I'm using a PreSonus Audiobox USB.  According to the manufacturer this is a pre-certified device so there is not driver for it, should be plug and play.  I have it set as a shared shared USB Device in VitrualBox settings and the OS seems to be detecting it.  However the volume bar is greyed out and, of course, I'm not hearing anything.


see pics:






I'm not sure this is a problem with the Audiobox per se.  I unplugged the Audiobox and put my speakers directly into my onboard soundcard, activated Audio in Virtual box, and booted.  Then it didn't detect any sound output devices at all.  


I've tried installing with and without Audio kexts.

I have downloaded, run, and installed  "all-in-one Audio-solution/

Still no results.  


Any assistance would be greatly appreciated.  I have seen other reports of the Presonus Audiobox working with this arrangement.




Intel Core i5-4590

eVGA Geforce 970 GTX

Asus Z97-A Motherboard

Intel i218-V Gigabit LAN (onbaord LAN)

Realtek ALC892 (onboard Audio)

Presonus Audiobox USB (External USB Audio, prefer to make this work)

Windows 7 sp1

Virtual Box v4.3.22

Share this post

Link to post
Share on other sites

Same problem here ! 

configuration: Mobo Asus P5Q Deluxe / CPU Q9550 / GPU Sapphire AMD RADEON HD 6570 2GB

LAN = Marvell 88E8056/88E8001 = works ok

Audio = ADI® AD2000B = does not work

Windows 7sp1 x64

VirtualBox 4.3.40 r 110317


Additional Notes

Mountain Lion (iAtkos ML2) worked with sound and network.

All distros I tested in virtualbox, log-off user when about this Mac is pressed

I could not work any other distros from Niresh or Zone on VirtualBox

Share this post

Link to post
Share on other sites

SOLUTION: :rofl:

with kext wizard, i Installed the following kexts taken from the library of another virtual machine installed  (iAtkos ML audio Kexts)

AppleFWAudio.kext / AppleHDA.kext / AudioAUUC.kext / IOAudioFamily.kext


Further Addition

Niresh Mavericks was installed out of the box with lan + sound + no shut down problems                           on a Dell Optiplex 755 SFF with the addition of a Sapphire Radeon HD5450 1Gb DDR3 64bit graphics card. (It also runs with the onboard Intel graphics but with a limited resolution of 1024x768)


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...