Jump to content

Recommended Posts

ok here goes I've been building hackintoshes for a while both amd and intel nvidia and ati right now im typing this on a asus a55a (specs: i7 3610qm 8gb ddr3 so-dimm ram intel hd4000 graphics) and it work flawlessly i recently gave my friend my hackintosh desktops because he had no computers at all so i gave him both and converted one back to windows one was a amd 6 core and the other an i5 dual core both worked flawlessly and both were using the Gainward gtx 460 gs 2gb ok now my problem:

ok installation on both boards is no problem its after the installation i see the boot screen with the bar and the apple or MaconPC logo then a grey screen with a rainbow cursor i have tried on both boards and both graphics cards and same issue every time i have been at this now for well over a week day in and day out if i back up all graphics kext during installation i can boot without using -x but as soon as i install any ati driver for those cards its back to the same way once again i have tried different installations every boot flag under the sun every kernel i can find but its defiantly a graphics driver issue please someone tell me there is a solution to this

heres a list all the parts i have





THIS IS NOW SOLVED :) :) :) :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram


i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel


inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite


you will also need amd webkit patch


now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

I have also posted the guide 


here: https://www.maconpc.com/topic/6016-fixguide-amd-stuck-at-greywhite-screen-with-spinning-beachball-fixguide/


and here: https://www.maconpc.com/topic/6015-fixguide-amd-stuck-at-greywhite-screen-with-spinning-beachball-fixguide/



enjoy :)



  • Like 1

Share this post

Link to post
Share on other sites

Here i linked the full procedure:https://www.maconpc.com/topic/5637-installation-issues-with-amd/page-2#entry21521

For what concernes the set-up, i suggest you to use the gigabyte mobo (with arguments pcirootuid=1) and the gigabyte video card, ram and CPU doesn't matter.....

Once you finished the installation, follow my instruction in the link.... Pretty sure it'will work like a charm ;)

Share this post

Link to post
Share on other sites



first post in this page for kernel and system kext, 5 post after (Carlo_67's post) kext to replace, also download and install new niresh's amd webkit


where to put all this files:


S/L/Kernel ------> kernel

S/L/Extension --------->  System and the 2 other kext


Then reboot in safe mode, install webkit and add -f (ignore kernel chache) in boot arg.

Reboot normally

Share this post

Link to post
Share on other sites

@Simone Rucci









in verbose mode no matter what flags i ise i get this just before the screen of rainbow cursor infinite appears

Controller ATI: SB600 (vendor ID: 1002, device ID: 4383)
Controller ATI: (Unknown) (vendor ID: 1002, device ID: aab0)
error: invalid CORB size: 00
error getCapabillities failed
Previous shutdown cause: 3
IOGraphics flags 0x43

Share this post

Link to post
Share on other sites

OK, I think I have details that might help.


I have the same exact motherboard and similar graphics card and same issue.


1) On safe mode, I get 1024x768 and my monitor is 1080p. The thing is that safe mode recognizes the graphics card as 7xxx/ R9 series. (My graphics card is the R9 280x Sapphire TriX)


2) I had the same problem on Mavericks 10.9.5 which I solved by reverting some kexts. The kexts I rolled back were these :  IOHIDFamily, IOPCIFamily and AppleACPIPlatform

They were rolled back to the 10.9.0 version and it worked perfectly. These kexts DO NOT LOAD under Yosemite since they are meant for a different version. I don't know if somebody can make them work with Yosemite or if there is some other way to work this out.


I have tried different kernels with no success. Still get the rainbow cursor. The thing is that it boots with GE=Yes and the cursor moves as if the graphics card is enabled and it seems to be running on 1080p. It is not laggy and the resolution looks a lot like 1080p. It just doesn't boot the UI... Please help!!

Share this post

Link to post
Share on other sites

It works! Perfect!


Now the only problem is that I cannot enable USB 3.0 from my MoBo. Did you have this problem?


Cheers! Thank you very very much!

Share this post

Link to post
Share on other sites

i am currently having that problem i instead whilst i solve it am using a usb 3.0 pcie card

OK, I made it work. 


Go to your BIOS and find the USB configuration option. There is a USB-EHCI Handoff selection. Set that to Enabled. Boot with -f and the GenericUSBXHCI fix and USB Bus Fix boot flags from Chameleon Wizard afterwards. It should work perfectly. It shows 4 USB 3.0 ports, but it works anyways.





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...