Jump to content
Sign in to follow this  

App store , Face Time FIX en0

Recommended Posts


Hope this can solve the problem.

Open the System Preferences app and go to the Network section. On the left-hand column in the Network section, select each of the items and remove it by clicking the minus sign on the bottom of the column.

Then, go to /Library/Preferences/SystemConfiguration in your main hard drive and delete NetworkInterfaces.plist. Or alternatively, drag it to the desktop (as a backup, in case things go wrong).

By removing all of the Network items in System Preferences and deleting NetworkInterfaces.plist, you have effectively reset the network configuration for Mac OS X. Reboot (you may have to reconfigure your internet connection afterwards).  


removing your network interfaces and rebooting, the order you reinstall your network interfaces is important. 

After you reboot, go back to your System Preferences > Network. Click the + button at the bottom of the left column. On the window that comes up, choose Ethernet first! (Important! I chose Wi-fi first my initial time through, and it didn't fix the problem). Click Apply. Then click + again and add your wi-fi. Click apply again, and your wi-fi should connect.

At this point, I rebooted, and tried an App Store update again, and it worked!

If Ethernet is not an option on your drop-down, then close the settings, open up Multibeast, and install a network driver (for me it was the Intel1000 driver). Once you've installed the driver from Multibeast, reboot again. Then go back to System Preferences > Network, click the + and you should see Ethernet in the drop-down. Create Ethernet first, and then click Apply. Then go back and add Wi-fi.

The reason why you have to add Ethernet first (afaik) is to ensure it's set as en0. en0 en0.


Shoutout to @tonymacx86.com/ and @KUROSAGI and @JasonHears there for posting this and @sis735 here for pointing out an error in my post  .tnx hope it helps !! For me it worked just followed this instruction and rebooted worked right after it booted up internet was already ReConfigured automatically for me hope it does for you too tnx again and keep having a good day !!

Share this post

Link to post
Share on other sites

No this can't solve always the problem. i tryed this many time but without success.

dont forget this :

1- Ethernet card must be en0

2- Add NVRam lib in Extra Modules

3- When using Clover booloader uncheck FIXLAN in configuration file.

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...