Jump to content
Sign in to follow this  
Bill Sherlock Hedges

Cannot boot installer

Recommended Posts

Trying to boot to the installer but I get instant reboot after the following:


Setting Legacy USB Off on controller
Legacy USB Off Done

I am using the following flag (I tried a variation - I need USBBusFix=Yes otherwise it fails even earlier):


-v kcsuffix=amd USBBusFix=Yes
-v kcsuffix=amd USBBusFix=Yes USBLegacyOff=Yes
-v kcsuffix=amd USBBusFix=Yes USBLegacyOff=No
-v kcsuffix=amd USBBusFix=Yes USBLegacyOff=No PCIRootUID=1
-v kcsuffix=amd USBBusFix=Yes USBLegacyOff=No PCIRootUID=1 npci=0x2000
-v kcsuffix=amd USBBusFix=Yes USBLegacyOff=No PCIRootUID=1 npci=0x3000

All my USB devices turn off just before it reboots, so I'm guessing it loses connection to the USB install media - but I can't work out why it's disabling all the USB's.

CPU: AMD FX 8350 (8-core)
RAM: 12GB HyperX Fury
Motherboard: AsRock Fatal1ty 990FX Killer
GPU: Gigabyte 4GB NVIDIA GTX 960

Share this post

Link to post
Share on other sites

Disabled all USB 3.0 Ports

Tried Enable and disable Legacy Support on off for USB 3.0 (XHCI).

And all possible all USB Settings.

Booted with Clover

with kcsuffix=amd npci=0x3000 dart=0 -v

tried dart=0 and USBBusFix=Yes with same result.

At Language selection screen only first USB port is working, so cannot use keyboard and mouse at a time. Have to use one at a time.

Used Apple Magic Keyboard with Mouse Connected

Then two error line rolling and rolling fast stating "Apple USB....<Can't Read>.....USBSTS Set USB not working as expected".

Cannot take pictures as it's rolling too fast.


AMD FX 9590

ASUS Sabertooth R2.0

Share this post

Link to post
Share on other sites

By disabling EHCI Handoff and HPET now I am at Installing.

Installing on a new HDD with GUID. PT.

Partitioning New HDD with Sierra Zone is PITAss.

Never shows Correct Volume size (Set one and Changes to One after partitioning).

Installing failed 10 times with different combinations, first time "Can not move NVIDIA.kext", after that "Installation failed due to an Error".

No clue beside that.

Tried Chameleon but failed to go to the language selection screen.

Waiting for any help or clue.

Share this post

Link to post
Share on other sites

USBBusFix=Yes is a chameleon boot-flag, if you want to configure usb settings in clover, You have to look in Options menu

Try kcsuffix=amd1


Try booting with Chameleon bootloader, to initialize chameleon bootloader Keep pressing number 2 while it starts booting from USB

Share this post

Link to post
Share on other sites

@Niresh I tried both amd and amd1 now as kernel using kcsuffix boot flag, now getting the following error:
Error allocating 0x1655 pages at 0x....c7a000 alloc type 2
Error loading kernel cache (0x9)
Boot failed, sleeping for 10 seconds before exiting...

Currently searching Google to see if I can find an answer but if you know what this is that'd be great. I have already tried with 'nv_disable=1'

Tried booting Chameleon by pressing 2 as you suggested - a couple of times it kept booting to Clover, but one time it went to a black screen and nothing else?

Share this post

Link to post
Share on other sites

Okay got past that error - it was the "slide=0" default boot flag, removed that. Now stuck on [PCI configuration begin]. Attempting to use the 'PCIRootUID=1' boot flag but using shift causes the P key to repeat a hell of a lot, going to see if I can get around this one.

Will also try booting Chameleon again shortly if I don't get around the key repeat issue in Clover.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...