Jump to content
Sign in to follow this  

Niresh 10.9 cannot get to installer

Recommended Posts

Niresh 10.9 cannot get to installer


Hi. I have a dell optiplex gx 620 pentium D 820 3 gb ram nividia 512mb ddr2 gs 8400 , i have seen a video on youtube     https://www.youtube.com/watch?v=rt4mnR3MU9M

that guy has installed mavericks on dell gx 620 so, i downloaded niresh osx10.9 & created bootable usb  but every time i  try to boot to installer using bootflags -v -x  or others 

it shows a black screen either im using the on board graphics or the gs 8400  WHAT CAN I DO ??


Share this post

Link to post
Share on other sites

Hello, Sir @bilal2404

i am sorry to hear you had problems with hackintosh

Your model is: dell optiplex gx 620 pentium D 820 3gb ram nvidia 512 ddr2 gs 8400

it seems to be a old model

i recommend to upgrade your videocard to a nvidia geforce 600 series with 1 gb ram mac os will run smoother. in case 512 mb is very low but i dont know how mac os x runs on your laptop since mac os x mavericks is not a operating system when you need high end pc so thats good but your ram seems to be ok,

Recommended ram is also: 4 gb but i do not have problems when i also use 3 gb ram bc my pc does have 8 but i had a old pc which had 3 gb i could also run mac smooth on pc with 3 gb ram


So i dont understand the problem very good so what for black screen do you see a cursor flickering or is the screen just black and it does nothing


Do you use Clover or Chameleon as bootloader: if you use clover the problem may is that its missing OsxAptioFix2Drv-64 which you can search a tutorial for how to install OsxAptioFix2Drv

To install the following file (OsxAptioFix2Drv) you need clover configurator.

Maybe upload a ss or pm it to me so i can look maybe i understand the error different so do u know whats causing the error but you can't find the solution may also say to me if it logs/outputs on the screen a error and it hangs also report it to me or to @Niresh may you not able to pm him bc he only responds on forums.

If it gives you only a black screen it must be a file thats missing or the pc can't find the kernel in s/l/k system/library/kernels/kernel to boot up or you missing a requird file dependency to boot up mac os installer i hope you'll respond fast if the error dissapeared in one time and you didn't know why it maybe could be a boot bug or your usb flash drive was not detected anymore


Also try if you have windows try with transmac to burn the files again on the usb 

For mac see tutorials on hackintosh.


If i couldn't help you soon and you have the problem still try vanilla method see tutorials on https://www.maconpc.com there are some tutorials out there that may help. 

sorry for my english

I am a dutch person, i will try to improve my english to talk on internet and in real to improve my social envoirement with people to talk so my english will be better.

-- Demy

Share this post

Link to post
Share on other sites

No, There is no cursor flickering just a black screen

When I try to boot mavericks with -v bootflag the setup begins with all the text  loading  but takes about 2-3 sec on system/library/extension m kext , loads 2 more lines and then resolution changes from 720x something to 1024x 768 black screen with nothing on it , i even left it for bout 2 hours but no use, thinking that it might be loading.

i tried some boot flags like GraphicsEnabler=Yes/No  PCIRootUID=1/0 etc but still no success. I have tried using the on board graphics but still the same issue

Im new to this hackintosh stuff and don't know much about it, i'll even try to upload pics of what is going on with the system. Searched the internet and got to know that gs 8400 is hackintosh compatible 


and if i try to boot straight into the installer, the system ends up with a grey stretched apple logo screen  

Share this post

Link to post
Share on other sites

Did you tried vanilla way


is your laptop running smooth for macOS?

already tried to boot with safe mode

maybe you are selecting a other kernel or you just need to add the bootflag -x means safe mode boot


Or try the vanilla way

Your model seems to be a old model try also to add bootlfag npci=0x2000

otherwise you will be stuck at pci configuration begin

i do always boot with -v if i want to boot to installer

if that didn’t work

try to disable prelinkedkernelcache by adding bootflag: UseKernelCache=No

or if no bootflag either work then its maybe a corrupted kernel and maybe macos can’t boot to the installer.


Also let me know which bootloader you use? and which version latest or older.

Did you tried to reburn all the files on the usb with transmac on windows maybe that could fix corrupted or missing files.


or you need a custom kernel for dell i dont know which kernel but i will take my time to search for you if you need a custom kernel.


Next time include a screenshot.

– Demy


Share this post

Link to post
Share on other sites

Dear Demy,

I have tried the boot flags but still the same issue .Take a look at the screen shots i've uploaded






bootflag -v 




the black screen appears after loading & reading "Extension.mkext " file 

Share this post

Link to post
Share on other sites



I made a video and snapped the last text displayed on the screen before the black screen


Share this post

Link to post
Share on other sites

The guy has even installed yosemite 10.10  https://www.youtube.com/watch?v=7H_1WQZK5qU

I searched the internet and found his post 

Bal3nis  : 

"Yes, I have Mavericks on Dell Optiplex gx620. It works well. Not so good for gaming though, so I recommend dual booting if you like to play video games. In addition, you should use a PCIx video card, and a PCi sound card. I found a soundblaster live in my Garage, and found the drivers for it. If there is enough interest, I will post instructions, and upload the Kernel and audio drivers. I used Niresh, then upgraded to 10.9.5. I then, using another mac, moved the kernel to the root directory, and it works. I have a Pentium D in my Dell. I actually used the Niresh Iso to boot using Easy BCD in Windows 7. When the computer starts up, I am able to select which Os I want. If your HD is smaller (mine is 750 gigs) you can dual boot using the chameleon bootloader instead of going through Windows and Easy BCD. Niresh's ML 10.8.2 also works without having to mess with the kernel, but takes 2 minutes to boot up. Also ML needs the boot flag, "UseKernelCache=No." In addition, I could not find a kernel that would run 10.8.5 at normal speed. The time clock literally changes minutes every 3 seconds! Mavericks takes around 40 seconds to boot. Not to shabby for an ancient computer! I have yet to try Yosemite, But I suspect that it will work with software update, and then finding a kernel that will boot it.  There are many tutorials for running 10.6.8 on gx620, but it is kind of a pain to find web browsers that work fully. 


I have an MSI N610GT 2G video card. It works OOB on Mavericks, but needs Driver for ML. I have it running to my TV via HDMI. One day, I may get audio working on HDMI, but for now, I have it running on AUX out of the Soundblaster into my Bose sound system. We watch movies and play online video games on it. "

but he is offline since march 2017 


So what u think might be the solution

Share this post

Link to post
Share on other sites

Yippee!!!!! hahahaha i managed to get to the installer.

just downloaded mach_kernel file & replaced it with the one on usb , now installing 

hope nothing else goes wrong cross fingers !!!!

Share this post

Link to post
Share on other sites

okay, now the same thing is happening after installation , the same grey icon and black screen with -v bootflag


now what can i do


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...